summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/qt-features-webos/qt-features-webos.bb')
-rw-r--r--meta/recipes-webos/qt-features-webos/qt-features-webos.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-webos/qt-features-webos/qt-features-webos.bb b/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
new file mode 100644
index 0000000000..984ba7dc25
--- /dev/null
+++ b/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
@@ -0,0 +1,36 @@
+# Copyright (c) 2013-2018 LG Electronics, Inc.
+
+SUMMARY = "Common Qt features for webOS components"
+AUTHOR = "Anupam Kaul <anulam.kaul@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "qtbase"
+
+WEBOS_VERSION = "1.0.0-1_67a99fc04d01e3025d137f7d50b0aa15016c4525"
+PR = "r4"
+
+inherit webos_qmake5
+inherit webos_enhanced_submissions
+inherit webos_public_repo
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+SRC_URI += "file://qt.patch"
+
+FILES_${PN}-dev += "${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs"
+
+# An empty package is needed to satisfy package dependencies when building bdk.
+ALLOW_EMPTY_${PN} = "1"
+
+BBCLASSEXTEND = "native"
+
+do_configure_class-native() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S}/tools/generate_qmap
+}
+
+do_install_class-native() {
+ oe_runmake install INSTALL_ROOT=${D}
+}