summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/pmloglib/pmloglib.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/pmloglib/pmloglib.bb')
-rwxr-xr-xmeta/recipes-webos/pmloglib/pmloglib.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-webos/pmloglib/pmloglib.bb b/meta/recipes-webos/pmloglib/pmloglib.bb
new file mode 100755
index 0000000000..fcc2edb5c4
--- /dev/null
+++ b/meta/recipes-webos/pmloglib/pmloglib.bb
@@ -0,0 +1,30 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "webOS logging library"
+AUTHOR = "Gayathri Srinivasan <gayathri.srinivasan@lge.com>"
+SECTION = "webos/libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "glib-2.0 libpbnjson"
+
+WEBOS_VERSION = "3.3.0-1_1de57d269d4c6cc2dba93c4683acc22cbc2ecb35"
+PR = "r9"
+
+LEAD_SONAME = "libPmLogLib.so"
+WEBOS_DISTRO_PRERELEASE ??= ""
+EXTRA_OECMAKE += "-DWEBOS_DISTRO_PRERELEASE:STRING='${WEBOS_DISTRO_PRERELEASE}'"
+
+inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_library
+inherit webos_prerelease_dep
+inherit webos_pmlog_config
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[whitelist] = "-DENABLE_WHITELIST:BOOL=TRUE, -DENABLE_WHITELIST:BOOL=FALSE"
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"