summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/nyx-utils/nyx-utils.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/nyx-utils/nyx-utils.bb')
-rw-r--r--meta/recipes-webos/nyx-utils/nyx-utils.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-webos/nyx-utils/nyx-utils.bb b/meta/recipes-webos/nyx-utils/nyx-utils.bb
new file mode 100644
index 0000000000..c96f277505
--- /dev/null
+++ b/meta/recipes-webos/nyx-utils/nyx-utils.bb
@@ -0,0 +1,23 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "Command line utilities for the webOS Platform Portability Layer"
+AUTHOR = "Ed Chejlava <ed.chejlava@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "nyx-lib glib-2.0"
+
+WEBOS_VERSION = "1.5.0-1_31fae17542c46ff0f6b5a8e0bbf1461d61881f2a"
+PR = "r2"
+
+inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_program
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${libdir}/nyx/nyxcmd/"