summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/nyx-lib/nyx-lib.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/nyx-lib/nyx-lib.bb')
-rw-r--r--meta/recipes-webos/nyx-lib/nyx-lib.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-webos/nyx-lib/nyx-lib.bb b/meta/recipes-webos/nyx-lib/nyx-lib.bb
new file mode 100644
index 0000000000..fb7d9acc39
--- /dev/null
+++ b/meta/recipes-webos/nyx-lib/nyx-lib.bb
@@ -0,0 +1,32 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "webOS portability layer - library"
+AUTHOR = "Keith Derrick <keith.derrick@lge.com>"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+SECTION = "webos/libs"
+
+# nyx-lib needs nyx-modules at runtime, but a runtime dependency is not defined
+# here because nyx-modules is MACHINE_ARCH (e.g. qemux86), while nyx-lib is
+# TUNE_PKGARCH (e.g. i586). Instead, it is pulled into the image by adding it to
+# the RDPENDS_${PN} of packagegroup-webos-extended. Putting
+# RDEPENDS_${PN} = "nyx-modules"
+# here would cause bitbake to re-execute the do_package task for each MACHINE,
+# even if these MACHINE-s were all i586 and should therefore share the same nyx-lib
+# .ipk and sstate files. (The reason do_package is re-executed when a component
+# in any of the R* variables is re-built is because its package name is stored in
+# this component's .ipk and it may have changed because debian.bbclass is inherited.)
+
+DEPENDS = "glib-2.0 pmloglib"
+
+WEBOS_VERSION = "7.3.0-1_fa1ed2c0365ece68282e8d26951de1f043874a6c"
+PR = "r7"
+
+inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_library
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"