summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/libpbnjson/libpbnjson.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/libpbnjson/libpbnjson.bb')
-rw-r--r--meta/recipes-webos/libpbnjson/libpbnjson.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-webos/libpbnjson/libpbnjson.bb b/meta/recipes-webos/libpbnjson/libpbnjson.bb
new file mode 100644
index 0000000000..b6691165db
--- /dev/null
+++ b/meta/recipes-webos/libpbnjson/libpbnjson.bb
@@ -0,0 +1,39 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "Palm's Better Native JSON library"
+AUTHOR = "Anatolii Sakhnik <anatolii.sakhnik@lge.com>"
+SECTION = "webos/libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "yajl glib-2.0 gperf-native flex-native lemon-native gmp uriparser boost"
+
+WEBOS_VERSION = "2.15.0-1_bdfbf107257bbe674c5e3b85b02c7cba419ea2aa"
+PR = "r7"
+
+inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_library
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_append_class-native = " tools"
+
+# These are the defaults, but explicitly specify so that readers know they exist
+EXTRA_OECMAKE += "-DWITH_DOCS:BOOL=FALSE -DWITH_TESTS:BOOL=FALSE -DNO_LOGGING:BOOL=TRUE"
+# Disable #line statements in autogenerated files
+EXTRA_OECMAKE += "-DLEMON_WITH_LINE:BOOL=FALSE"
+# Don't use CMake detection mechanisms for AR (it fails for class-native)
+EXTRA_OECMAKE += "-DCMAKE_AR:FILEPATH=${AR}"
+
+PACKAGECONFIG[tools] = "-DPBNJSON_INSTALL_TOOLS:BOOL=TRUE,-DPBNJSON_INSTALL_TOOLS:BOOL=FALSE"
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+# Otherwise it fails with:
+# libpbnjson-native/2.15.0-68-r7/git/src/pbnjson_c/validation/schema_builder.c:24:10: fatal error: schema_keywords.h: No such file or directory
+OECMAKE_GENERATOR="Unix Makefiles"