aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-tbd/meta/meta-toolchain.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-tbd/meta/meta-toolchain.bb')
-rw-r--r--meta/recipes-tbd/meta/meta-toolchain.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-tbd/meta/meta-toolchain.bb b/meta/recipes-tbd/meta/meta-toolchain.bb
index 2fab8f94b2..633f5f1990 100644
--- a/meta/recipes-tbd/meta/meta-toolchain.bb
+++ b/meta/recipes-tbd/meta/meta-toolchain.bb
@@ -72,8 +72,15 @@ do_populate_sdk() {
#rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
- # Link the ld.so.cache file into the hosts filesystem
- ln -s /etc/ld.so.cache ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.cache
+ # Create an appropriate setup so the dynamic loader can find libs in
+ # both the host system and the toolchain directories
+ echo ${SDKPATHNATIVE}${libdir} > ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
+ echo ${SDKPATHNATIVE}${base_libdir} >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
+ echo "include /etc/ld.so.conf" >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
+ echo "#!/bin/sh" > ${SDK_OUTPUT}/${SDKPATH}/postinstall
+ echo "ldconfig -f ${SDKPATHNATIVE}/etc/ld.so.conf -C /${SDKPATHNATIVE}/etc/ld.so.cache" >> ${SDK_OUTPUT}/${SDKPATH}/postinstall
+ chmod a+x ${SDK_OUTPUT}/${SDKPATH}/postinstall
+
# Setup site file for external use
siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}