summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim/vim_8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vim/vim_8.2.bb')
-rw-r--r--meta/recipes-support/vim/vim_8.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-support/vim/vim_8.2.bb b/meta/recipes-support/vim/vim_8.2.bb
new file mode 100644
index 0000000000..709b6ddb55
--- /dev/null
+++ b/meta/recipes-support/vim/vim_8.2.bb
@@ -0,0 +1,15 @@
+require vim.inc
+
+PROVIDES = "xxd"
+
+PACKAGECONFIG_class-native = ""
+BBCLASSEXTEND = "native"
+
+ALTERNATIVE_${PN}_append = " xxd"
+ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
+ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"
+
+# We override the default in security_flags.inc because vim (not vim-tiny!) will abort
+# in many places for _FORTIFY_SOURCE=2. Security flags become part of CC.
+#
+lcl_maybe_fortify = "${@oe.utils.conditional('DEBUG_BUILD','1','','-D_FORTIFY_SOURCE=1',d)}"