aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb
new file mode 100644
index 00000000000..55d8b9e95b7
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.52.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "An HTTP library implementation in C"
+HOMEPAGE = "http://www.gnome.org/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SECTION = "x11/gnome/libs"
+
+DEPENDS = "glib-2.0 gnutls libxml2 sqlite3 intltool-native"
+
+EXTRA_OECONF = "--disable-vala"
+
+# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
+# by default but let it be easily disabled.
+PACKAGECONFIG ??= "gnome"
+PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
+
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "b80f11674724ab38f96426875bc0e2e5"
+SRC_URI[sha256sum] = "0e19bca047ad50b28e8ed7663840f9e45a94909148822ca44dcb3e8cafb5cc48"
+
+S = "${WORKDIR}/libsoup-${PV}"
+
+inherit autotools gettext pkgconfig
+
+# glib-networking is needed for SSL, proxies, etc.
+RRECOMMENDS_${PN} = "glib-networking"