aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.34.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.34.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.34.bb b/meta/recipes-support/libpcre/libpcre_8.34.bb
index 0c2b0828b1..5c5072cb90 100644
--- a/meta/recipes-support/libpcre/libpcre_8.34.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.34.bb
@@ -9,7 +9,10 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
file://pcre-cross.patch \
- file://fix-pcre-name-collision.patch"
+ file://fix-pcre-name-collision.patch \
+ file://run-ptest \
+ file://Makefile \
+"
SRC_URI[md5sum] = "5439e321351bddd5533551bbce128d07"
SRC_URI[sha256sum] = "b6043ae1ff2720be665ffa28dc22b7c637cdde96f389a116c0c3020caeae583f"
@@ -21,7 +24,7 @@ DEPENDS += "bzip2 zlib"
PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
-inherit autotools binconfig
+inherit autotools binconfig ptest
PARALLEL_MAKE = ""
@@ -56,3 +59,15 @@ FILES_pcretest = "${bindir}/pcretest"
FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
BBCLASSEXTEND = "native nativesdk"
+
+do_install_ptest() {
+ t=${D}${PTEST_PATH}
+ cp ${WORKDIR}/Makefile $t
+ cp -r ${S}/testdata $t
+ for i in pcre_stringpiece_unittest pcregrep pcretest; \
+ do cp ${B}/.libs/$i $t; \
+ done
+ for i in RunTest RunGrepTest test-driver; \
+ do cp ${S}/$i $t; \
+ done
+}