summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre/out-of-tree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre/out-of-tree.patch')
-rw-r--r--meta/recipes-support/libpcre/libpcre/out-of-tree.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre/out-of-tree.patch b/meta/recipes-support/libpcre/libpcre/out-of-tree.patch
new file mode 100644
index 0000000000..687dcc034d
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre/out-of-tree.patch
@@ -0,0 +1,26 @@
+In out-of-tree builds the #include fails because $srcdir isn't in the include path. Set CPPFLAGS so that it is.
+
+Upstream-Status: Submitted [https://bugs.exim.org/show_bug.cgi?id=2379]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+Index: configure.ac
+===================================================================
+--- a/configure.ac (revision 1749)
++++ b/configure.ac (working copy)
+@@ -159,6 +159,8 @@
+
+ if test "$enable_jit" = "auto"; then
+ AC_LANG(C)
++ SAVE_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=-I$srcdir
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #define SLJIT_CONFIG_AUTO 1
+ #include "sljit/sljitConfigInternal.h"
+@@ -165,6 +167,7 @@
+ #if (defined SLJIT_CONFIG_UNSUPPORTED && SLJIT_CONFIG_UNSUPPORTED)
+ #error unsupported
+ #endif]])], enable_jit=yes, enable_jit=no)
++ CPPFLAGS=$SAVE_CPPFLAGS
+ fi
+
+ # Handle --disable-pcregrep-jit (enabled by default)