aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch')
-rw-r--r--meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
index b93d97b1b7..79aa0bdf11 100644
--- a/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
+++ b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
@@ -6,24 +6,24 @@ newer version so we can assume this issue is fixed upstream
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-Index: libnl-3.2.14/lib/Makefile.am
+Index: libnl-3.2.25/lib/Makefile.am
===================================================================
---- libnl-3.2.14.orig/lib/Makefile.am
-+++ libnl-3.2.14/lib/Makefile.am
-@@ -39,9 +39,12 @@ CLEANFILES = \
+--- libnl-3.2.25.orig/lib/Makefile.am
++++ libnl-3.2.25/lib/Makefile.am
+@@ -46,9 +46,12 @@ CLEANFILES = \
# Hack to avoid using ylwrap. It does not function correctly in combination
# with --header-file=
+route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
+route/pktloc_grammar.h: route/pktloc_grammar.c
route/pktloc_grammar.c: route/pktloc_grammar.l
- $(AM_V_GEN) $(FLEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+ $(AM_V_GEN) $(MKDIR_P) route; $(FLEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+route/pktloc_syntax.h: route/pktloc_syntax.c
route/pktloc_syntax.c: route/pktloc_syntax.y
- $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
+ $(AM_V_GEN) $(MKDIR_P) route; $(YACC) -d $(YFLAGS) -o $@ $^
-@@ -89,7 +92,9 @@ BUILT_SOURCES = \
+@@ -102,7 +105,9 @@ BUILT_SOURCES = \
route/cls/ematch_grammar.c \
route/cls/ematch_syntax.c \
route/pktloc_grammar.c \