aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch')
-rw-r--r--meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch b/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
new file mode 100644
index 0000000000..d9f00be2b6
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
@@ -0,0 +1,22 @@
+12/03/2010
+
+add explicit rules for header files generated by lex and yacc,
+otherwise the build of lib/route/pktloc.c may fail in a parallel
+environment.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index 92a916e..e8b8ef3 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -35,6 +35,10 @@ route/pktloc_grammar.c: route/pktloc_grammar.l
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+
++route/pktloc.$(OBJEXT): route/pktloc_syntax.h route/pktloc_grammar.h
++route/pktloc_syntax.h: route/pktloc_syntax.c
++route/pktloc_grammar.h: route/pktloc_grammar.c
++
+ libnl_route_la_LDFLAGS = -version-info 2:0:0
+ libnl_route_la_LIBADD = libnl.la
+ libnl_route_la_SOURCES = \