summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/files/ptest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gdbm/files/ptest.patch')
-rw-r--r--meta/recipes-support/gdbm/files/ptest.patch40
1 files changed, 25 insertions, 15 deletions
diff --git a/meta/recipes-support/gdbm/files/ptest.patch b/meta/recipes-support/gdbm/files/ptest.patch
index 65236fb48b..1e67dbd554 100644
--- a/meta/recipes-support/gdbm/files/ptest.patch
+++ b/meta/recipes-support/gdbm/files/ptest.patch
@@ -1,30 +1,40 @@
-Add install-ptest rules.
+From 41448708e163c8ec1f980464e7dd6741db427c8a Mon Sep 17 00:00:00 2001
+From: Josep Puigdemont <josep.puigdemont@enea.com>
+Date: Sun, 4 May 2014 16:02:07 +0200
+Subject: [PATCH] Add install-ptest rules.
Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com>
Signed-off-by: Maxin B. John <maxin.john@enea.com>
Upstream-Status: Pending
-diff -ur a/Makefile.am b/Makefile.am
---- a/Makefile.am 2011-08-16 10:13:10.000000000 +0200
-+++ b/Makefile.am 2013-04-12 18:02:16.473715873 +0200
-@@ -31,3 +31,8 @@
- d=`date '+%d/%m/%Y'`; \
- sed 's|/\*@DIST_DATE@\*/|"'"$$d"'"|' $(srcdir)/src/version.c > \
- $(distdir)/src/version.c
+---
+ Makefile.am | 5 +++++
+ tests/Makefile.am | 11 +++++++++++
+ 2 files changed, 16 insertions(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index ecc03df..9fbbda5 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -55,3 +55,8 @@ ChangeLog:
+ awk -f $(top_srcdir)/git2chg.awk \
+ -v append=$(top_srcdir)/$(prev_change_log) > ChangeLog; \
+ fi
+
+install-ptest:
+ @for subdir in $(SUBDIRS); do \
+ $(MAKE) -C $$subdir DESTDIR=$(DESTDIR)/$$subdir $@; \
+ done
-diff -ur a/tests/Makefile.am b/tests/Makefile.am
---- a/tests/Makefile.am 2011-11-11 19:39:42.000000000 +0100
-+++ b/tests/Makefile.am 2013-04-12 18:30:57.066301037 +0200
-@@ -132,4 +132,14 @@
- dtdel_LDADD = ../src/libgdbm.la ../compat/libgdbm_compat.la
- d_creat_ce_LDADD = ../src/libgdbm.la ../compat/libgdbm_compat.la
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index dbe17dd..06f537f 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -169,3 +169,14 @@ EXTRA_DIST += \
+ gdbmtool/base.exp\
+ config/default.exp
+buildtests: $(check_PROGRAMS) $(TESTSUITE)
-
++
+install-ptest: $(check_PROGRAMS) $(TESTSUITE)
+ @$(INSTALL) -d $(DESTDIR)
+ @for file in $^; do \