summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.74.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.74.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.74.0.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.74.0.bb b/meta/recipes-support/boost/bjam-native_1.74.0.bb
index d843eb038c..c0eeed60b0 100644
--- a/meta/recipes-support/boost/bjam-native_1.74.0.bb
+++ b/meta/recipes-support/boost/bjam-native_1.74.0.bb
@@ -5,16 +5,14 @@ SECTION = "devel"
inherit native
-SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
- file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
- "
-
do_compile() {
./bootstrap.sh --with-toolset=gcc
}
do_install() {
install -d ${D}${bindir}/
- # install unstripped version for bjam
- install -c -m 755 b2 ${D}${bindir}/bjam
+ install b2 ${D}${bindir}/bjam
}
+
+# The build is either release mode (pre-stripped) or debug (-O0).
+INSANE_SKIP_${PN} = "already-stripped"