aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bmap-tools/bmap-tools_3.4.bb')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_3.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
new file mode 100644
index 0000000000..3f75fad44b
--- /dev/null
+++ b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
+DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
+bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
+and copying files using the block map. The idea is that large file containing \
+unused blocks, like raw system image files, can be copied or flashed a lot \
+faster with bmaptool than with traditional tools like "dd" or "cp"."
+HOMEPAGE = "https://github.com/01org/bmap-tools"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/01org/bmap-tools.git"
+SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "python-core python-compression python-mmap"
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"
+
+do_install_append_class-native() {
+ sed -i -e 's|^#!.*/usr/bin/python-native/python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
+}