aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/atk/at-spi2-atk_2.22.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/atk/at-spi2-atk_2.22.0.bb')
-rw-r--r--meta/recipes-support/atk/at-spi2-atk_2.22.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-support/atk/at-spi2-atk_2.22.0.bb b/meta/recipes-support/atk/at-spi2-atk_2.22.0.bb
new file mode 100644
index 00000000000..80ba64279b3
--- /dev/null
+++ b/meta/recipes-support/atk/at-spi2-atk_2.22.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AT-SPI 2 Toolkit Bridge"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886"
+
+MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
+
+SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "aa62aed21b8e03dc44ab81ae49d893ca"
+SRC_URI[sha256sum] = "e8bdedbeb873eb229eb08c88e11d07713ec25ae175251648ad1a9da6c21113c1"
+
+DEPENDS = "dbus glib-2.0 atk at-spi2-core"
+
+inherit autotools pkgconfig distro_features_check upstream-version-is-even
+
+# The at-spi2-core requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGES =+ "${PN}-gnome ${PN}-gtk2"
+
+FILES_${PN}-gnome = "${libdir}/gnome-settings-daemon-3.0/gtk-modules"
+FILES_${PN}-gtk2 = "${libdir}/gtk-2.0/modules/libatk-bridge.*"