aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr')
-rw-r--r--meta/recipes-support/apr/apr-util_1.4.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.4.1.bb b/meta/recipes-support/apr/apr-util_1.4.1.bb
index deb608f8de..0516bc4acc 100644
--- a/meta/recipes-support/apr/apr-util_1.4.1.bb
+++ b/meta/recipes-support/apr/apr-util_1.4.1.bb
@@ -32,8 +32,10 @@ inherit autotools lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-do_configure_prepend() {
- cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+do_configure_append() {
+ if [ "${PN}" == "${BPN}" ]; then
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ fi
}
do_configure_prepend_virtclass-native() {
cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk