aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web-webkit_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/web/web-webkit_svn.bb')
-rw-r--r--meta/recipes-sato/web/web-webkit_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web-webkit_svn.bb b/meta/recipes-sato/web/web-webkit_svn.bb
new file mode 100644
index 0000000000..9cdf1f9da3
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Multi-platform web browsing application."
+HOMEPAGE = "http://o-hand.com/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2"
+
+SECTION = "x11"
+DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
+ file://link-with-g++.patch;patch=1"
+
+S = "${WORKDIR}/webkit"
+
+EXTRA_OECONF = "--enable-libowl"
+
+inherit autotools pkgconfig gconf
+
+do_configure_prepend() {
+ touch ${S}/src/dummy.cpp
+}
+
+FILES_${PN} += "${datadir}/web2"