aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/settings-daemon/files')
-rw-r--r--meta/recipes-sato/settings-daemon/files/70settings-daemon.sh1
-rw-r--r--meta/recipes-sato/settings-daemon/files/addsoundkeys.patch49
-rw-r--r--meta/recipes-sato/settings-daemon/files/dso_linking_change_build_fix.patch31
3 files changed, 0 insertions, 81 deletions
diff --git a/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh b/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh
deleted file mode 100644
index 95374135f2..0000000000
--- a/meta/recipes-sato/settings-daemon/files/70settings-daemon.sh
+++ /dev/null
@@ -1 +0,0 @@
-/usr/bin/settings-daemon &
diff --git a/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch b/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch
deleted file mode 100644
index baf06d6b84..0000000000
--- a/meta/recipes-sato/settings-daemon/files/addsoundkeys.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Upstream-Status: Pending
-
-Index: settings-daemon/settings-daemon.c
-===================================================================
---- settings-daemon.orig/settings-daemon.c 2009-05-22 14:57:05.000000000 +0100
-+++ settings-daemon/settings-daemon.c 2009-05-22 14:58:22.000000000 +0100
-@@ -187,6 +187,10 @@
- GCONF_VALUE_STRING, translate_string_string },
- { "/desktop/poky/interface/gtk_color_scheme", "Gtk/ColorScheme",
- GCONF_VALUE_STRING, translate_string_string },
-+ { "/desktop/gnome/sound/theme_name", "Net/SoundThemeName",
-+ GCONF_VALUE_STRING, translate_string_string },
-+ { "/desktop/gnome/sound/event_sounds", "Net/EnableEventSounds" ,
-+ GCONF_VALUE_BOOL, translate_bool_int },
- };
-
- static const TranslationEntry*
-Index: settings-daemon/settings-daemon.schemas
-===================================================================
---- settings-daemon.orig/settings-daemon.schemas 2009-05-22 15:49:17.000000000 +0100
-+++ settings-daemon/settings-daemon.schemas 2009-05-22 15:51:31.000000000 +0100
-@@ -196,6 +196,27 @@
- </locale>
- </schema>
-
-+ <schema>
-+ <key>/schemas/desktop/gnome/sound/theme_name</key>
-+ <applyto>/desktop/gnome/sound/theme_name</applyto>
-+ <owner>gnome</owner>
-+ <type>string</type>
-+ <default>freedesktop</default>
-+ <locale name="C">
-+ <short>Sound Theme Name</short>
-+ </locale>
-+ </schema>
-+
-+ <schema>
-+ <key>/schemas/desktop/gnome/sound/event_sounds</key>
-+ <applyto>/desktop/gnome/sound/event_sounds</applyto>
-+ <owner>gnome</owner>
-+ <type>bool</type>
-+ <default>true</default>
-+ <locale name="C">
-+ <short>Enable Sound Events</short>
-+ </locale>
-+ </schema>
-
- </schemalist>
- </gconfschemafile>
diff --git a/meta/recipes-sato/settings-daemon/files/dso_linking_change_build_fix.patch b/meta/recipes-sato/settings-daemon/files/dso_linking_change_build_fix.patch
deleted file mode 100644
index 594374467a..0000000000
--- a/meta/recipes-sato/settings-daemon/files/dso_linking_change_build_fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-after gcc linking has changed, all the libraries must be explicitely specified to for linking.
-This patch avoids this linking error:
-
-| make all-am^M
-| make[1]: Entering directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/settings-daemon-0.0+svnr2059-r3/settings-daemon'^M
-| ccache i586-poky-linux-gcc -march=i586 --sysroot=/disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux -Wall -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -o settings-daemon settings_daemon-xsettings-common.o settings_daemon-xsettings-manager.o settings_daemon-settings-daemon.o -pthread -lgconf-2 -ldbus-glib-1 -ldbus-1 -lpthread -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0^M
-| /disk0/pokybuild/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: *^A: invalid DSO for symbol `XCreateSimpleWindow' definition^M
-| /disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux/usr/lib/libX11.so.6: could not read symbols: Bad value^M
-| collect2: ld returned 1 exit status^M
-| make[1]: *** [settings-daemon] Error 1^M
-| make[1]: Leaving directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/settings-daemon-0.0+svnr2059-r3/settings-daemon'^M
-| make: *** [all] Error 2^M
-
-Nitin A Kamble <nitin.a.kamble@intel.com>
-Date: 2011/01/11
-
-Index: settings-daemon/configure.ac
-===================================================================
---- settings-daemon.orig/configure.ac
-+++ settings-daemon/configure.ac
-@@ -14,7 +14,7 @@ AC_PROG_CC
-
-
- dnl TODO: make gconf optional
--PKG_CHECK_MODULES(APP, [gconf-2.0 gdk-x11-2.0])
-+PKG_CHECK_MODULES(APP, [gconf-2.0 gdk-x11-2.0 x11])
-
-
- AC_SUBST(APP_CFLAGS)