aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r10286.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r10286.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r10286.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r10286.bb b/meta/recipes-sato/puzzles/puzzles_r10286.bb
new file mode 100644
index 0000000000..1ad8d1bf14
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r10286.bb
@@ -0,0 +1,59 @@
+SUMMARY = "Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+DEPENDS = "gtk+ libxt"
+MOD_PV = "${@d.getVar('PV',1)[1:]}"
+
+# The libxt requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
+
+SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV} \
+ file://fix-compiling-failure-with-option-g-O.patch \
+ file://puzzles_x32_abi_time.patch \
+"
+
+S = "${WORKDIR}/${BPN}"
+
+inherit autotools-brokensep distro_features_check
+
+do_configure_prepend () {
+ ./mkfiles.pl
+}
+
+FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*"
+FILES_${PN}-dbg += "${prefix}/bin/.debug"
+
+do_install () {
+ rm -rf ${D}/*
+ export prefix=${D}
+ export DESTDIR=${D}
+ install -d ${D}/${prefix}/bin/
+ oe_runmake install
+
+
+ install -d ${D}/${datadir}/applications/
+
+ # Create desktop shortcuts
+ cd ${D}/${prefix}/bin
+ for prog in *; do
+ if [ -x $prog ]; then
+ # Convert prog to Title Case
+ title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
+ echo "making ${D}/${datadir}/applications/$prog.desktop"
+ cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
+[Desktop Entry]
+Name=$title
+Exec=${prefix}/bin/$prog
+Icon=applications-games
+Terminal=false
+Type=Application
+Categories=Game;
+StartupNotify=true
+X-MB-SingleInstance=true
+STOP
+ fi
+ done
+}