aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop')
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch2
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/window-resize-fix.patch50
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_git.bb8
3 files changed, 4 insertions, 56 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch b/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch
index 0edb55e081..388f51f07f 100644
--- a/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch
+++ b/meta/recipes-sato/matchbox-desktop/files/dso_linking_change_build_fix.patch
@@ -11,7 +11,7 @@ This patch avoids this linking error:
Nitin A Kamble <nitin.a.kamble@intel.com>
Date: 2011/01/11
-Upstream-Status: Pending
+Upstream-Status: Accepted
Index: matchbox-desktop-2/configure.ac
===================================================================
diff --git a/meta/recipes-sato/matchbox-desktop/files/window-resize-fix.patch b/meta/recipes-sato/matchbox-desktop/files/window-resize-fix.patch
deleted file mode 100644
index 8970ac8445..0000000000
--- a/meta/recipes-sato/matchbox-desktop/files/window-resize-fix.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-commit 2ef9a98cbda46b5a52e20ce292eebd6ba1f3c3a8
-Author: Yu Ke <ke.yu@intel.com>
-Date: Sun Mar 6 17:58:45 2011 +0800
-
- desktop: Add configure event handler for desktop resize
-
- desktop need to resize its work area when window manager decorate its
- window. Originally it is done by the hook in root window PropertyNotify
- event handler, i.e. net_workarea_changed () routine. However, for unknown
- reason, the PropertyNotify event does not deliver to the root window,
- thus this routine does not work.
-
- this patch fix this issue from another side. Since window manager will also
- send configure event to desktop window after decoration, it also works to do
- it in configure event handler.
-
- Signed-off-by: Yu Ke <ke.yu@intel.com>
-
-Upstream-Status: Pending
-
-diff --git a/src/desktop.c b/src/desktop.c
-index d4fc2fb..5aa2cfc 100644
---- a/src/desktop.c
-+++ b/src/desktop.c
-@@ -130,6 +130,15 @@ workarea_changed (int x, int y, int w, int h)
- gtk_fixed_move (GTK_FIXED (fixed), box, x, y);
- }
-
-+static gboolean
-+desktop_configure_callback(GtkWindow *window,
-+ GdkEvent *event, gpointer data)
-+{
-+ gtk_widget_set_size_request (box, event->configure.width, event->configure.height);
-+ gtk_widget_queue_resize (box);
-+ return FALSE;
-+}
-+
- GtkWidget *
- create_desktop (void)
- {
-@@ -176,6 +185,9 @@ create_desktop (void)
- /* Set a sane default in case there is no work area defined yet */
- workarea_changed (0, 0, screen_w, screen_h);
-
-+ g_signal_connect(G_OBJECT(window), "configure-event",
-+ G_CALLBACK(desktop_configure_callback), NULL);
-+
- #ifdef STANDALONE
- /* TODO: fake workarea_changed calls on window resize */
- #else
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_git.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_git.bb
index a3dcec32f0..e2e3047f35 100644
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_git.bb
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_git.bb
@@ -10,13 +10,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
DEPENDS = "gtk+ startup-notification dbus"
SECTION = "x11/wm"
-SRCREV = "af7ed6775487380be73160aa0298bf6019765fad"
+SRCREV = "71e3e6e04271e9d5a14f1c231ef100c7f320134d"
PV = "2.0+git${SRCPV}"
-PR = "r1"
+PR = "r0"
-SRC_URI = "git://git.yoctoproject.org/${BPN}-2;protocol=git \
- file://dso_linking_change_build_fix.patch \
- file://window-resize-fix.patch"
+SRC_URI = "git://git.yoctoproject.org/${BPN}-2;protocol=git"
EXTRA_OECONF = "--enable-startup-notification --with-dbus"