aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
new file mode 100644
index 0000000000..012b2dd0a7
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Hardware latency detector"
+DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+require rt-tests.inc
+inherit python3-dir
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
+RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"