summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtwayland_git.bb72
1 files changed, 30 insertions, 42 deletions
diff --git a/meta/recipes-qt/qt5/qtwayland_git.bb b/meta/recipes-qt/qt5/qtwayland_git.bb
index 91ffcd771b..2934e3ade4 100644
--- a/meta/recipes-qt/qt5/qtwayland_git.bb
+++ b/meta/recipes-qt/qt5/qtwayland_git.bb
@@ -1,53 +1,41 @@
require qt5.inc
require qt5-git.inc
-DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native"
-DEPENDS_append_class-target = " libxkbcommon"
-
-LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+# There are no LGPLv3-only licensed files in this component.
+LICENSE = "BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
- file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+ file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
+ file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
+ file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
+ file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-PACKAGECONFIG ?= " \
- wayland-client \
- wayland-server \
- wayland-egl \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \
+# wayland-native is already in wayland DEPENDS, but add it here
+# explicitly, because it's native wayland-scanner we're looking for
+# libxkbcommon isn't mandatory make it easier to remove by .bbappend
+# (e.g. for building qtwayland with danny which doesn't have libxkbcommon in oe-core).
+XKB_DEPENDS = "libxkbcommon xproto"
+DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS}"
+
+QT_WAYLAND_CONFIG ?= "wayland-compositor"
+QT_WAYLAND_DEFINES ?= ""
+
+EXTRA_QMAKEVARS_PRE += "CONFIG+=${QT_WAYLAND_CONFIG}"
+EXTRA_QMAKEVARS_PRE += "DEFINES+=${QT_WAYLAND_DEFINES}"
+
+FILES_${PN}-plugins += " \
+ ${OE_QMAKE_PATH_PLUGINS}/*/*/*${SOLIBSDEV} \
+"
+
+FILES_${PN}-plugins-dbg += " \
+ ${OE_QMAKE_PATH_PLUGINS}/*/*/.debug/* \
"
-PACKAGECONFIG_class-native ?= ""
-PACKAGECONFIG_class-nativesdk ?= ""
-QMAKE_PROFILES_class-native = "${S}/src/qtwaylandscanner"
-QMAKE_PROFILES_class-nativesdk = "${S}/src/qtwaylandscanner"
-B_class-native = "${SEPB}/src/qtwaylandscanner"
-B_class-nativesdk = "${SEPB}/src/qtwaylandscanner"
-
-PACKAGECONFIG[wayland-client] = "-feature-wayland-client,-no-feature-wayland-client"
-PACKAGECONFIG[wayland-server] = "-feature-wayland-server,-no-feature-wayland-server"
-PACKAGECONFIG[xcomposite-egl] = "-feature-xcomposite-egl,-no-feature-xcomposite-egl,libxcomposite"
-PACKAGECONFIG[xcomposite-glx] = "-feature-xcomposite-glx,-no-feature-xcomposite-glx,virtual/mesa"
-PACKAGECONFIG[wayland-egl] = "-feature-wayland-egl,-no-feature-wayland-egl,virtual/egl"
-PACKAGECONFIG[wayland-brcm] = "-feature-wayland-brcm,-no-feature-wayland-brcm,virtual/egl"
-PACKAGECONFIG[drm-egl-server] = "-feature-drm-egl-server,-no-feature-drm-egl-server,libdrm virtual/egl"
-PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature-libhybris-egl-server,libhybris"
-
-EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-
-SRCREV = "db36bc0d9ccae21e84cd54be3e18ae539542eadc"
-
-# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.10
-# 5.10.meta-qt5.2
-# From https://bugreports.qt.io/browse/QTBUG-57767
+
+# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.6
+# 5.6.meta-qt5.1
SRC_URI += " \
- file://0001-fix-build-without-xkbcommon-evdev.patch \
+ file://0001-examples-wayland-include-server-buffer-only-when-bui.patch \
"
-BBCLASSEXTEND =+ "native nativesdk"
-
-# The same issue as in qtbase:
-# http://errors.yoctoproject.org/Errors/Details/152641/
-LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+SRCREV = "70575643cfece4f0aca4b40e77ac5d7c0e8042a2"