aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/lame/lame_3.99.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/lame/lame_3.99.5.bb')
-rw-r--r--meta/recipes-multimedia/lame/lame_3.99.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/lame/lame_3.99.5.bb b/meta/recipes-multimedia/lame/lame_3.99.5.bb
new file mode 100644
index 0000000000..a0c4cf5c65
--- /dev/null
+++ b/meta/recipes-multimedia/lame/lame_3.99.5.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "LAME is an educational tool to be used for learning about MP3 encoding."
+HOMEPAGE = "http://sourceforge.net/projects/lame/files/lame/"
+BUGTRACKER = "http://sourceforge.net/tracker/?group_id=290&atid=100290"
+SECTION = "console/utils"
+LICENSE = "LGPLv2+"
+LICENSE_FLAGS = "commercial"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=c46bda00ffbb0ba1dac22f8d087f54d9 \
+ file://include/lame.h;beginline=1;endline=20;md5=a2258182c593c398d15a48262130a92b \
+"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
+ file://no-gtk1.patch"
+
+SRC_URI[md5sum] = "84835b313d4a8b68f5349816d33e07ce"
+SRC_URI[sha256sum] = "24346b4158e4af3bd9f2e194bb23eb473c75fb7377011523353196b19b9a23ff"
+
+inherit autotools
+
+PACKAGES += "libmp3lame libmp3lame-dev"
+FILES_${PN} = "${bindir}/lame"
+FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
+FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
+FILES_${PN}-dev = ""
+
+do_configure() {
+ # no autoreconf please
+ aclocal
+ autoconf
+ libtoolize --force
+ gnu-configize --force
+ oe_runconf
+}