aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/kmod/kmod/fix-undefined-O_CLOEXEC.patch17
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch29
-rw-r--r--meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch52
3 files changed, 0 insertions, 98 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/fix-undefined-O_CLOEXEC.patch b/meta/recipes-kernel/kmod/kmod/fix-undefined-O_CLOEXEC.patch
deleted file mode 100644
index 0268216230..0000000000
--- a/meta/recipes-kernel/kmod/kmod/fix-undefined-O_CLOEXEC.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Not applicable
-
-Index: git/libkmod/libkmod-private.h
-===================================================================
---- git.orig/libkmod/libkmod-private.h 2013-08-21 10:07:51.000000000 -0700
-+++ git/libkmod/libkmod-private.h 2013-08-21 14:34:04.558278849 -0700
-@@ -9,6 +9,10 @@
- #include "macro.h"
- #include "libkmod.h"
-
-+#ifndef O_CLOEXEC
-+# define O_CLOEXEC 0
-+#endif
-+
- static _always_inline_ _printf_format_(2, 3) void
- kmod_log_null(struct kmod_ctx *ctx, const char *format, ...) {}
-
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch
deleted file mode 100644
index 5d531d65e4..0000000000
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Currently default header is linux-libc-header, which leads the dismatch
-with wrs kernel.
-
-The different headers for same file cause trouble between kerenl module and
-user level binary. E.g. segfault in v86d due to different
-CONNECTOR_MAX_MSG_SIZE in connector.h from the one used by uvesafb.
-
-This fix is work around to sync with wrs kernel headers, and should be removed
-after switching to linux-libc-headers-wrs.
-
-[BUGID #279] fixed by this.
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-
-Index: linux-2.6.34/include/linux/connector.h
-===================================================================
---- linux-2.6.34.orig/include/linux/connector.h 2010-09-30 14:15:25.000000000 +0800
-+++ linux-2.6.34/include/linux/connector.h 2010-09-30 14:15:43.000000000 +0800
-@@ -48,7 +48,7 @@
- /*
- * Maximum connector's message size.
- */
--#define CONNECTOR_MAX_MSG_SIZE 16384
-+#define CONNECTOR_MAX_MSG_SIZE 65536
-
- /*
- * idx and val are unique identifiers which
diff --git a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch b/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
deleted file mode 100644
index d07335a5f7..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: tools/perf/Makefile
-===================================================================
---- a/tools/perf/Makefile 2011-01-14 14:17:33.127008554 -0600
-+++ b/tools/perf/Makefile 2011-01-14 14:18:14.227008548 -0600
-@@ -588,42 +588,8 @@
- endif
- endif
-
--ifdef NO_LIBPERL
-- BASIC_CFLAGS += -DNO_LIBPERL
--else
-- PERL_EMBED_LDOPTS = $(shell perl -MExtUtils::Embed -e ldopts 2>/dev/null)
-- PERL_EMBED_LDFLAGS = $(call strip-libs,$(PERL_EMBED_LDOPTS))
-- PERL_EMBED_LIBADD = $(call grep-libs,$(PERL_EMBED_LDOPTS))
-- PERL_EMBED_CCOPTS = `perl -MExtUtils::Embed -e ccopts 2>/dev/null`
-- FLAGS_PERL_EMBED=$(PERL_EMBED_CCOPTS) $(PERL_EMBED_LDOPTS)
--
-- ifneq ($(call try-cc,$(SOURCE_PERL_EMBED),$(FLAGS_PERL_EMBED)),y)
-- BASIC_CFLAGS += -DNO_LIBPERL
-- else
-- ALL_LDFLAGS += $(PERL_EMBED_LDFLAGS)
-- EXTLIBS += $(PERL_EMBED_LIBADD)
-- LIB_OBJS += $(OUTPUT)util/scripting-engines/trace-event-perl.o
-- LIB_OBJS += $(OUTPUT)scripts/perl/Perf-Trace-Util/Context.o
-- endif
--endif
--
--ifdef NO_LIBPYTHON
-- BASIC_CFLAGS += -DNO_LIBPYTHON
--else
-- PYTHON_EMBED_LDOPTS = $(shell python-config --ldflags 2>/dev/null)
-- PYTHON_EMBED_LDFLAGS = $(call strip-libs,$(PYTHON_EMBED_LDOPTS))
-- PYTHON_EMBED_LIBADD = $(call grep-libs,$(PYTHON_EMBED_LDOPTS))
-- PYTHON_EMBED_CCOPTS = `python-config --cflags 2>/dev/null`
-- FLAGS_PYTHON_EMBED=$(PYTHON_EMBED_CCOPTS) $(PYTHON_EMBED_LDOPTS)
-- ifneq ($(call try-cc,$(SOURCE_PYTHON_EMBED),$(FLAGS_PYTHON_EMBED)),y)
-- BASIC_CFLAGS += -DNO_LIBPYTHON
-- else
-- ALL_LDFLAGS += $(PYTHON_EMBED_LDFLAGS)
-- EXTLIBS += $(PYTHON_EMBED_LIBADD)
-- LIB_OBJS += $(OUTPUT)util/scripting-engines/trace-event-python.o
-- LIB_OBJS += $(OUTPUT)scripts/python/Perf-Trace-Util/Context.o
-- endif
--endif
-+BASIC_CFLAGS += -DNO_LIBPERL
-+BASIC_CFLAGS += -DNO_LIBPYTHON
-
- ifdef NO_DEMANGLE
- BASIC_CFLAGS += -DNO_DEMANGLE