summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb8
3 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
index d85c6c4829..10f2901112 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -3,6 +3,14 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
+# board specific branches
+KBRANCH_qemuarm = "standard/arm-versatile-926ejs"
+KBRANCH_qemumips = "standard/mti-malta32"
+KBRANCH_qemuppc = "standard/qemuppc"
+KBRANCH_qemux86 = "standard/common-pc/base"
+KBRANCH_qemux86-64 = "standard/common-pc-64/base"
+KBRANCH_qemumips64 = "standard/mti-malta64"
+
SRCREV_machine_qemuarm ?= "7744145fcc3e4b6b6e308a1b86dc1c8b237b7575"
SRCREV_machine_qemumips ?= "2b8e8c694c38729ce724facdb0ab20751d061a2e"
SRCREV_machine_qemuppc ?= "9a7537cb9bcc5c835dae6ac84fbbe7298473f69c"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 9b8456fd6f..765d4deec7 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -3,6 +3,14 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
+# board specific branches
+KBRANCH_qemuarm = "standard/arm-versatile-926ejs"
+KBRANCH_qemumips = "standard/mti-malta32"
+KBRANCH_qemuppc = "standard/qemuppc"
+KBRANCH_qemux86 = "standard/common-pc/base"
+KBRANCH_qemux86-64 = "standard/common-pc-64/base"
+KBRANCH_qemumips64 = "standard/mti-malta64"
+
SRCREV_machine_qemuarm ?= "38fe75106c5faa3ea49d0a285769de3d08478f90"
SRCREV_machine_qemumips ?= "67c8918ce3cfd66f19f23b46381993ff488b3fe0"
SRCREV_machine_qemuppc ?= "0e81c96b36e05746ae978a830fe3dbdac8a51e58"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
index 20fce1b981..dfc67bd9c0 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -3,6 +3,14 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
+# board specific branches
+KBRANCH_qemuarm = "standard/arm-versatile-926ejs"
+KBRANCH_qemumips = "standard/mti-malta32"
+KBRANCH_qemuppc = "standard/qemuppc"
+KBRANCH_qemux86 = "standard/common-pc/base"
+KBRANCH_qemux86-64 = "standard/common-pc-64/base"
+KBRANCH_qemumips64 = "standard/mti-malta64"
+
SRCREV_machine_qemuarm ?= "aa76cc28408376814752bd36fb0dcf0e25aa5ba3"
SRCREV_machine_qemumips ?= "aa0affda03c955678b26b2fb586f1d9505127871"
SRCREV_machine_qemumips64 ?= "077bff22c9951db6b35470ba17b1df2f2a91fefb"