aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch')
-rw-r--r--meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch b/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
new file mode 100644
index 0000000000..49b0209029
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+
+Subject: Makefile.am: fix parallel build problem
+
+Fix parallel build problem to avoid errors like below.
+
+ install: cannot stat 'testsuite/module-playground/mod-fake-cciss.ko': No such file or directory
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 9457655..d5b02eb 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -237,7 +237,7 @@ rootfs: build-module-playground
+
+ .PHONY: rootfs build-playground
+
+-$(ROOTFS): $(ROOTFS_PRISTINE)
++$(ROOTFS): $(ROOTFS_PRISTINE) build-module-playground
+ $(CREATE_ROOTFS)
+
+ TESTSUITE_OVERRIDE_LIBS = \
+--
+1.9.1
+