aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/dtc/dtc/remove_space_opt.patch')
-rw-r--r--meta/recipes-kernel/dtc/dtc/remove_space_opt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
new file mode 100644
index 0000000000..805bf58796
--- /dev/null
+++ b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
@@ -0,0 +1,16 @@
+Remove the -Os flag
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -18,7 +18,7 @@ CONFIG_LOCALVERSION =
+ CPPFLAGS = -I libfdt
+ WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
+ -Wstrict-prototypes -Wmissing-prototypes
+-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
++CFLAGS = -g -fPIC -Werror $(WARNINGS)
+
+ BISON = bison
+ LEX = flex