aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/clutter/cogl.inc22
-rw-r--r--meta/recipes-graphics/clutter/cogl/build_for_armv4t.patch23
-rw-r--r--meta/recipes-graphics/clutter/cogl/macro-versions.patch28
-rw-r--r--meta/recipes-graphics/clutter/cogl_1.8.2.bb12
-rw-r--r--meta/recipes-graphics/clutter/cogl_git.bb16
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0.inc58
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb7
7 files changed, 65 insertions, 101 deletions
diff --git a/meta/recipes-graphics/clutter/cogl.inc b/meta/recipes-graphics/clutter/cogl.inc
deleted file mode 100644
index 26f7889ca4..0000000000
--- a/meta/recipes-graphics/clutter/cogl.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "a modern 3D graphics API with associated utility APIs"
-HOMEPAGE = "http://wiki.clutter-project.org/wiki/Cogl"
-LICENSE = "LGPLv2.1+"
-
-STDDEPENDS = "virtual/libx11 pango glib-2.0 libxfixes gdk-pixbuf libxi"
-BASE_CONF = "${@get_clutter_fpu_setting(bb, d)}"
-
-DEPENDS = "${STDDEPENDS} virtual/libgl libxcomposite libxdamage libdrm"
-EXTRA_OECONF = "${BASE_CONF} --with-flavour=glx"
-
-FILESPATH = "${FILE_DIRNAME}/cogl"
-
-inherit autotools pkgconfig gtk-doc gettext
-
-#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
-require clutter-fpu.inc
-
-#Fix up some weirdness in the docs
-do_configure_prepend() {
- sed -i s:doc/reference/Makefile::g ${S}/configure.ac
- sed -i s:doc::g ${S}/Makefile.am
-}
diff --git a/meta/recipes-graphics/clutter/cogl/build_for_armv4t.patch b/meta/recipes-graphics/clutter/cogl/build_for_armv4t.patch
deleted file mode 100644
index 003e9ff5fa..0000000000
--- a/meta/recipes-graphics/clutter/cogl/build_for_armv4t.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-GCC will define __ARM_ARCH_4T__ when building with "-march=armv4t" so we can
-check this to turn off the use of 'clz' instructions, which otherwise would
-cause compile errors like "selected processor does not support ARM mode
-`clz r3,r0'".
-
-Upstream-Status: Accepted (should be in the next cogl stable release)
-
-Signed-off-by: Wolfgang Denk <wd@denx.de>
-Signed-off-by: Joshua Lock <josh@linux.intel.com>
-
-Index: cogl-1.8.2/cogl/cogl-fixed.c
-===================================================================
---- cogl-1.8.2.orig/cogl/cogl-fixed.c
-+++ cogl-1.8.2/cogl/cogl-fixed.c
-@@ -626,7 +626,7 @@ cogl_fixed_sqrt (CoglFixed x)
- /*
- * Find the highest bit set
- */
--#if defined (__arm__)
-+#if defined (__arm__) && !defined(__ARM_ARCH_4T__)
- /* This actually requires at least arm v5, but gcc does not seem
- * to set the architecture defines correctly, and it is I think
- * very unlikely that anyone will want to use clutter on anything
diff --git a/meta/recipes-graphics/clutter/cogl/macro-versions.patch b/meta/recipes-graphics/clutter/cogl/macro-versions.patch
deleted file mode 100644
index 2dcdd8e800..0000000000
--- a/meta/recipes-graphics/clutter/cogl/macro-versions.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: cogl-1.8.0/configure.ac
-===================================================================
---- cogl-1.8.0.orig/configure.ac
-+++ cogl-1.8.0/configure.ac
-@@ -833,7 +833,7 @@ LT_INIT([disable-static])
- dnl ================================================================
- dnl I18n stuff.
- dnl ================================================================
--AM_GNU_GETTEXT_VERSION([0.17])
-+AM_GNU_GETTEXT_VERSION([0.18])
- AM_GNU_GETTEXT([external])
-
- GETTEXT_PACKAGE="cogl"
-Index: cogl-1.8.0/po/Makefile.in.in
-===================================================================
---- cogl-1.8.0.orig/po/Makefile.in.in
-+++ cogl-1.8.0/po/Makefile.in.in
-@@ -9,7 +9,7 @@
- # General Public License and is *not* in the public domain.
- #
- # Origin: gettext-0.17
--GETTEXT_MACRO_VERSION = 0.17
-+GETTEXT_MACRO_VERSION = 0.18
-
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
diff --git a/meta/recipes-graphics/clutter/cogl_1.8.2.bb b/meta/recipes-graphics/clutter/cogl_1.8.2.bb
deleted file mode 100644
index fe4266b4a6..0000000000
--- a/meta/recipes-graphics/clutter/cogl_1.8.2.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-require cogl.inc
-
-PR = "r3"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-
-SRC_URI = "http://source.clutter-project.org/sources/cogl/1.8/${BPN}-${PV}.tar.bz2 \
- file://macro-versions.patch \
- file://build_for_armv4t.patch"
-
-SRC_URI[md5sum] = "3145cbf7ff162c33065ea4421c047e2f"
-SRC_URI[sha256sum] = "8b647b51a4fa93034fcd74ffe86b3d4c919b0e54789108f6d065414e6162ab73"
diff --git a/meta/recipes-graphics/clutter/cogl_git.bb b/meta/recipes-graphics/clutter/cogl_git.bb
deleted file mode 100644
index 3fb70ae153..0000000000
--- a/meta/recipes-graphics/clutter/cogl_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require cogl.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-
-# the 1.8.2 tag
-SRCREV = "e398e374e2ff0e88bc1d63577a192f8ca04a1cb5"
-PV = "1.8.2+git${SRCPV}"
-PR = "r4"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "git://git.gnome.org/cogl;protocol=git;branch=master \
- file://build_for_armv4t.patch"
-S = "${WORKDIR}/git"
-
-AUTOTOOLS_AUXDIR = "${S}/build"
diff --git a/meta/recipes-graphics/cogl/cogl-1.0.inc b/meta/recipes-graphics/cogl/cogl-1.0.inc
new file mode 100644
index 0000000000..17d8629eb9
--- /dev/null
+++ b/meta/recipes-graphics/cogl/cogl-1.0.inc
@@ -0,0 +1,58 @@
+DESCRIPTION = "a modern 3D graphics API with associated utility APIs"
+HOMEPAGE = "http://wiki.clutter-project.org/wiki/Cogl"
+LICENSE = "LGPLv2.1+"
+
+inherit clutter
+
+DEPENDS = "gtk-doc-native pango glib-2.0 gdk-pixbuf"
+PACKAGES =+ "${PN}-examples"
+AUTOTOOLS_AUXDIR = "${S}/build"
+
+# Extra DEPENDS for PACKAGECONFIG
+EDEPENDS_GL = "virtual/libgl libdrm"
+EDEPENDS_GLES2 = "virtual/libgles2"
+EDEPENDS_KMS = "libdrm virtual/egl"
+EDEPENDS_EGL = "virtual/egl"
+EDEPENDS_X11 = "virtual/libx11 libxcomposite libxfixes libxi"
+
+# Extra RDEPENDS for PACKAGECONFIG
+# This has to be explictly listed, because cogl dlopens the backends
+ERDEPENDS_GL = "libgl"
+ERDEPENDS_GLES2 = "libgles2"
+
+EXTRA_OECONF += "--disable-introspection \
+ --disable-gtk-doc \
+ ${@get_fpu_setting(bb, d)} \
+ --enable-examples-install \
+ --enable-debug \
+ --disable-gl \
+ --disable-gles1 \
+ --disable-gles2 \
+ --disable-glx \
+ "
+
+# GL flavours
+PACKAGECONFIG[gl] = "--enable-gl,,${EDEPENDS_GL},${ERDPENDS_GL}"
+PACKAGECONFIG[gles2] = "--enable-gles2,,${EDEPENDS_GLES2}, ${ERDEPENDS_GLES2}"
+
+# egl backends
+PACKAGECONFIG[egl-kms] = "--enable-kms-egl-platform,,${EDEPENDS_KMS}"
+PACKAGECONFIG[egl-null] = "--enable-null-egl-platform"
+PACKAGECONFIG[egl-x11] = "--enable-xlib-egl-platform,,${EDEPENDS_X11}"
+
+# glx
+PACKAGECONFIG[glx] = "--enable-gl --enable-glx, ${EDEPENDS_GL} ${EDEPENDS_X11}"
+
+# Default to GLX
+PACKAGECONFIG ??= "glx"
+
+#Fix up some weirdness in the docs
+do_configure_prepend() {
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+
+ # Disable DOLT
+ sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
+
+FILES_${PN}-examples = "${bindir}/* ${datadir}/cogl/examples-data/*"
diff --git a/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb b/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb
new file mode 100644
index 0000000000..0f40c595ac
--- /dev/null
+++ b/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb
@@ -0,0 +1,7 @@
+
+require cogl-1.0.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[archive.md5sum] = "7eabaf4241c0b87cc9e3b0fa23fd0315"
+SRC_URI[archive.sha256sum] = "276e8c9f5ff0fcd57c1eaf74cc245f41ad469a95a18ac831fac2d5960baa5ae8"