aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch')
-rw-r--r--meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch24
1 files changed, 18 insertions, 6 deletions
diff --git a/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch b/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
index ae9640ce0c..5028fd6bf1 100644
--- a/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
+++ b/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
@@ -1,10 +1,22 @@
-Upstream-Status: Inappropriate [configuration]
+Use relative symlink for link rather than absolute path which
+doesn't work well in DESTDIR setting.
-diff -ur xcursor-transparent-theme-0.1.1~/cursors/Makefile.am xcursor-transparent-theme-0.1.1/cursors/Makefile.am
---- xcursor-transparent-theme-0.1.1~/cursors/Makefile.am 2003-10-30 12:13:59.000000000 +0000
-+++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2004-07-27 12:56:24.000000000 +0100
-@@ -91,6 +91,6 @@
- $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
+Also fix out of tree builds to use correct srcdir.
+
+Upstream-Status: Pending
+
+RP 2013/3/8
+
+Index: xcursor-transparent-theme-0.1.1/cursors/Makefile.am
+===================================================================
+--- xcursor-transparent-theme-0.1.1.orig/cursors/Makefile.am 2013-03-07 22:25:03.933435307 +0000
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2013-03-07 22:25:27.293434755 +0000
+@@ -88,9 +88,9 @@
+
+ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(CURSOR_DIR);
+- $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
++ $(INSTALL_DATA) $(srcdir)/$(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
for CURSOR in $(CURSOR_NAMES); do \
echo '-- Installing cursor '$$CURSOR; \
- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \