aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common/x11-common_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/x11-common/x11-common_0.1.bb')
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index 156b329486..6d7c347c00 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -9,14 +9,21 @@ inherit distro_features_check
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = "file://etc \
+ file://Xserver.in \
file://gplv2-license.patch"
S = "${WORKDIR}"
+PACKAGECONFIG ??= "blank"
+# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
+PACKAGECONFIG[blank] = ""
+
do_install() {
cp -R ${S}/etc ${D}${sysconfdir}
+ sed -e 's/@BLANK_ARGS@/${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}/' \
+ ${S}/Xserver.in > ${D}${sysconfdir}/X11/Xserver
+
chmod -R 755 ${D}${sysconfdir}
- find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
}
RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"