aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common/x11-common_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/x11-common/x11-common_0.1.bb')
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
new file mode 100644
index 0000000000..6791f961a1
--- /dev/null
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Common X11 scripts"
+LICENSE = "GPLv2"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xdpyinfo xtscal xinit formfactor"
+PR = "r38"
+
+SRC_URI = "file://etc"
+S = ${WORKDIR}
+
+PACKAGE_ARCH = "all"
+
+do_install() {
+ cp -R ${S}/etc ${D}/etc
+ chmod -R 755 ${D}/etc
+ find ${D}/etc -type d -name .svn -prune -exec rm -rf {} \;
+ find ${D}/etc -type f -name \*~ -exec rm -rf {} \;
+}