aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston/parallelmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston/parallelmake.patch')
-rw-r--r--meta/recipes-graphics/wayland/weston/parallelmake.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston/parallelmake.patch b/meta/recipes-graphics/wayland/weston/parallelmake.patch
new file mode 100644
index 0000000000..34d7512b9e
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston/parallelmake.patch
@@ -0,0 +1,22 @@
+The current approach used by the Makefile ends up installing
+weston.desktop twice and can give build failures when using
+parallel make flags. Change to just have one DATA reference.
+
+RP
+2015/8/3
+Upstream-Status: Pending
+
+Index: weston-1.8.0/Makefile.am
+===================================================================
+--- weston-1.8.0.orig/Makefile.am
++++ weston-1.8.0/Makefile.am
+@@ -179,8 +179,7 @@ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = src/weston.pc
+
+ wayland_sessiondir = $(datadir)/wayland-sessions
+-wayland_session_DATA = src/weston.desktop
+-dist_wayland_session_DATA = $(wayland_session_DATA)
++dist_wayland_session_DATA = src/weston.desktop
+
+ westonincludedir = $(includedir)/weston
+ westoninclude_HEADERS = \