aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch')
-rw-r--r--meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch b/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
new file mode 100644
index 0000000000..817ac70a15
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
@@ -0,0 +1,22 @@
+Index: weston-1.5.0/configure.ac
+===================================================================
+--- weston-1.5.0.orig/configure.ac
++++ weston-1.5.0/configure.ac
+@@ -491,8 +491,16 @@ AC_ARG_ENABLE(demo-clients-install,
+ enable_demo_clients_install=no)
+ AM_CONDITIONAL(INSTALL_DEMO_CLIENTS, [test "x$enable_demo_clients_install" = "xyes"])
+
++AC_ARG_ENABLE(lcms,
++ AS_HELP_STRING([--disable-lcms],
++ [disable lcms support]),,
++ enable_lcms=yes)
++
++AS_IF([test "x$enable_lcms" != "no"], [
+ PKG_CHECK_MODULES(LCMS, lcms2,
+- [have_lcms=yes], [have_lcms=no])
++ [have_lcms=yes], [have_lcms=no])],
++ [have_lcms=no])
++
+ if test "x$have_lcms" = xyes; then
+ AC_DEFINE(HAVE_LCMS, 1, [Have lcms support])
+ fi