aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch')
-rw-r--r--meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch68
1 files changed, 35 insertions, 33 deletions
diff --git a/meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch b/meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
index 9a401ee4b6..5542036be2 100644
--- a/meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
+++ b/meta/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
@@ -1,8 +1,8 @@
-From 228349e796e9baa86f2ba8232c730c18ac41283d Mon Sep 17 00:00:00 2001
+From d02226b3d5872b184c1d50c7f4706ac9467ffb81 Mon Sep 17 00:00:00 2001
From: Tom Hochstein <tom.hochstein@nxp.com>
-Date: Fri, 13 May 2016 09:31:55 -0500
-Subject: [PATCH weston] weston-launch: Provide a default version that doesn't
- require PAM
+Date: Fri, 15 Jul 2016 11:00:15 +0300
+Subject: [PATCH] weston-launch: Provide a default version that doesn't require
+ PAM
weston-launch requires PAM for starting weston as a non-root user.
@@ -14,18 +14,17 @@ Upstream-Status: Pending
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
---
- Makefile.am | 3 ---
- configure.ac | 12 +++++++-----
+ configure.ac | 9 +++++++--
src/weston-launch.c | 20 ++++++++++++++++++++
- 3 files changed, 27 insertions(+), 8 deletions(-)
+ 2 files changed, 27 insertions(+), 2 deletions(-)
-Index: weston-1.10.0/configure.ac
-===================================================================
---- weston-1.10.0.orig/configure.ac 2016-05-13 11:02:05.711817559 -0500
-+++ weston-1.10.0/configure.ac 2016-05-13 13:30:28.000000000 -0500
-@@ -445,13 +445,17 @@
- AS_IF([test "x$have_systemd_login_209" = "xyes"],
- [AC_DEFINE([HAVE_SYSTEMD_LOGIN_209], [1], [Have systemd-login >= 209])])
+diff --git a/configure.ac b/configure.ac
+index 32fdde7..240966f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -416,13 +416,17 @@ AC_ARG_ENABLE(resize-optimization,
+ AS_IF([test "x$enable_resize_optimization" = "xyes"],
+ [AC_DEFINE([USE_RESIZE_POOL], [1], [Use resize memory pool as a performance optimization])])
+AC_ARG_WITH(pam,
+ AS_HELP_STRING([--with-pam], [Use PAM]),
@@ -34,16 +33,16 @@ Index: weston-1.10.0/configure.ac
AM_CONDITIONAL(BUILD_WESTON_LAUNCH, test x$enable_weston_launch == xyes)
-if test x$enable_weston_launch == xyes; then
+if test x$enable_weston_launch = xyes -a x$use_pam = xyes; then
- AC_CHECK_LIB([pam], [pam_open_session], [have_pam=yes], [have_pam=no])
+ WESTON_SEARCH_LIBS([PAM], [pam], [pam_open_session], [have_pam=yes], [have_pam=no])
if test x$have_pam == xno; then
- AC_ERROR([weston-launch requires pam])
+ AC_ERROR([PAM support is explicitly requested, but libpam couldn't be found])
fi
+ AC_DEFINE([HAVE_PAM], [1], [Define if PAM is available])
- PAM_LIBS=-lpam
- AC_SUBST(PAM_LIBS)
fi
-@@ -667,6 +671,7 @@
+
+ AM_CONDITIONAL(HAVE_PANGO, test "x$have_pango" = "xyes")
+@@ -673,6 +677,7 @@ AC_MSG_RESULT([
Enable developer documentation ${enable_devdocs}
weston-launch utility ${enable_weston_launch}
@@ -51,10 +50,10 @@ Index: weston-1.10.0/configure.ac
systemd-login support ${have_systemd_login}
systemd notify support ${enable_systemd_notify}
-Index: weston-1.10.0/src/weston-launch.c
-===================================================================
---- weston-1.10.0.orig/src/weston-launch.c 2016-05-13 11:02:05.779817896 -0500
-+++ weston-1.10.0/src/weston-launch.c 2016-05-13 11:02:05.851818253 -0500
+diff --git a/src/weston-launch.c b/src/weston-launch.c
+index b8b2ba0..a865061 100644
+--- a/src/weston-launch.c
++++ b/src/weston-launch.c
@@ -51,7 +51,9 @@
#include <pwd.h>
@@ -65,7 +64,7 @@ Index: weston-1.10.0/src/weston-launch.c
#ifdef HAVE_SYSTEMD_LOGIN
#include <systemd/sd-login.h>
-@@ -93,8 +95,10 @@
+@@ -93,8 +95,10 @@ drmSetMaster(int drm_fd)
#endif
struct weston_launch {
@@ -76,7 +75,7 @@ Index: weston-1.10.0/src/weston-launch.c
int tty;
int ttynr;
int sock[2];
-@@ -181,6 +185,7 @@
+@@ -181,6 +185,7 @@ weston_launch_allowed(struct weston_launch *wl)
return false;
}
@@ -84,7 +83,7 @@ Index: weston-1.10.0/src/weston-launch.c
static int
pam_conversation_fn(int msg_count,
const struct pam_message **messages,
-@@ -221,6 +226,7 @@
+@@ -221,6 +226,7 @@ setup_pam(struct weston_launch *wl)
return 0;
}
@@ -92,7 +91,7 @@ Index: weston-1.10.0/src/weston-launch.c
static int
setup_launcher_socket(struct weston_launch *wl)
-@@ -414,6 +420,7 @@
+@@ -414,6 +420,7 @@ quit(struct weston_launch *wl, int status)
close(wl->signalfd);
close(wl->sock[0]);
@@ -100,7 +99,7 @@ Index: weston-1.10.0/src/weston-launch.c
if (wl->new_user) {
err = pam_close_session(wl->ph, 0);
if (err)
-@@ -421,6 +428,7 @@
+@@ -421,6 +428,7 @@ quit(struct weston_launch *wl, int status)
err, pam_strerror(wl->ph, err));
pam_end(wl->ph, err);
}
@@ -108,7 +107,7 @@ Index: weston-1.10.0/src/weston-launch.c
if (ioctl(wl->tty, KDSKBMUTE, 0) &&
ioctl(wl->tty, KDSKBMODE, wl->kb_mode))
-@@ -600,6 +608,7 @@
+@@ -600,6 +608,7 @@ setup_session(struct weston_launch *wl)
setenv("HOME", wl->pw->pw_dir, 1);
setenv("SHELL", wl->pw->pw_shell, 1);
@@ -116,7 +115,7 @@ Index: weston-1.10.0/src/weston-launch.c
env = pam_getenvlist(wl->ph);
if (env) {
for (i = 0; env[i]; ++i) {
-@@ -608,6 +617,7 @@
+@@ -608,6 +617,7 @@ setup_session(struct weston_launch *wl)
}
free(env);
}
@@ -124,7 +123,7 @@ Index: weston-1.10.0/src/weston-launch.c
}
static void
-@@ -665,7 +675,9 @@
+@@ -665,7 +675,9 @@ static void
help(const char *name)
{
fprintf(stderr, "Usage: %s [args...] [-- [weston args..]]\n", name);
@@ -134,7 +133,7 @@ Index: weston-1.10.0/src/weston-launch.c
fprintf(stderr, " -t, --tty Start session on alternative tty\n");
fprintf(stderr, " -v, --verbose Be verbose\n");
fprintf(stderr, " -h, --help Display this help message\n");
-@@ -678,7 +690,9 @@
+@@ -678,7 +690,9 @@ main(int argc, char *argv[])
int i, c;
char *tty = NULL;
struct option opts[] = {
@@ -144,7 +143,7 @@ Index: weston-1.10.0/src/weston-launch.c
{ "tty", required_argument, NULL, 't' },
{ "verbose", no_argument, NULL, 'v' },
{ "help", no_argument, NULL, 'h' },
-@@ -690,9 +704,13 @@
+@@ -690,9 +704,13 @@ main(int argc, char *argv[])
while ((c = getopt_long(argc, argv, "u:t::vh", opts, &i)) != -1) {
switch (c) {
case 'u':
@@ -158,7 +157,7 @@ Index: weston-1.10.0/src/weston-launch.c
break;
case 't':
tty = optarg;
-@@ -730,8 +748,10 @@
+@@ -730,8 +748,10 @@ main(int argc, char *argv[])
if (setup_tty(&wl, tty) < 0)
exit(EXIT_FAILURE);
@@ -169,3 +168,6 @@ Index: weston-1.10.0/src/weston-launch.c
if (setup_launcher_socket(&wl) < 0)
exit(EXIT_FAILURE);
+--
+2.1.4
+