aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.1.3.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.1.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.1.3.bb b/meta/recipes-graphics/mesa/mesa_18.1.3.bb
new file mode 100644
index 0000000000..c47c57e9d8
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.1.3.bb
@@ -0,0 +1,23 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ file://0002-Simplify-wayland-scanner-lookup.patch \
+ file://0003-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0004-hardware-gloat.patch \
+ file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
+ file://0006-Use-Python-3-to-execute-the-scripts.patch \
+ file://0007-dri-i965-Add-missing-time.h-include.patch \
+ file://0008-egl-fix-build-race-in-automake.patch \
+"
+
+SRC_URI[md5sum] = "b34273403a605f6f98ead00f0bdf8e0b"
+SRC_URI[sha256sum] = "54f08deeda0cd2f818e8d40140040ed013de7852573002453b7f50da9ea738ce"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}