aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.1.1.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.1.1.bb b/meta/recipes-graphics/mesa/mesa_18.1.1.bb
new file mode 100644
index 0000000000..aab4a19315
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.1.1.bb
@@ -0,0 +1,22 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ file://0002-Simplify-wayland-scanner-lookup.patch \
+ file://0003-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0004-hardware-gloat.patch \
+ file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
+ file://0006-Use-Python-3-to-execute-the-scripts.patch \
+ file://0007-dri-i965-Add-missing-time.h-include.patch \
+"
+
+SRC_URI[md5sum] = "063468c930ff61d211ece0191874fa95"
+SRC_URI[sha256sum] = "d3312a2ede5aac14a47476b208b8e3a401367838330197c4588ab8ad420d7781"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}