aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.0.2.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.0.2.bb b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
new file mode 100644
index 0000000000..aaac1e58e1
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
@@ -0,0 +1,22 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://disable-asm-on-non-gcc.patch \
+ file://Use-Python-3-to-execute-the-scripts.patch \
+ file://0001-Use-wayland-scanner-in-the-path.patch \
+ file://0002-hardware-gloat.patch \
+ file://llvm-config-version.patch \
+ file://0001-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ "
+
+SRC_URI[md5sum] = "3c303da98ec2ce37c795baeba5aee31e"
+SRC_URI[sha256sum] = "98fa159768482dc568b9f8bf0f36c7acb823fa47428ffd650b40784f16b9e7b3"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}