aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.1.1.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.1.bb b/meta/recipes-graphics/mesa/mesa_17.1.1.bb
new file mode 100644
index 0000000000..060a279015
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.1.1.bb
@@ -0,0 +1,19 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+ file://disable-asm-on-non-gcc.patch \
+ file://0001-Use-wayland-scanner-in-the-path.patch \
+ file://0001-util-rand_xor-add-missing-include-statements.patch \
+"
+
+SRC_URI[md5sum] = "a4844bc6052578574f9629458bcbb749"
+SRC_URI[sha256sum] = "aed503f94c0c1630a162a3e276f4ee12a86764cee4cb92338ea2dea99a04e7ef"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}