aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch b/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch
deleted file mode 100644
index 76b5a18ede..0000000000
--- a/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From e21ce89f7ae6964f196086ff325d79e4a3b5acd8 Mon Sep 17 00:00:00 2001
-From: Jonathan Liu <net147@gmail.com>
-Date: Tue, 4 Jun 2013 06:04:44 -0700
-Subject: [PATCH 1/4] configure: Avoid use of AC_CHECK_FILE for cross compiling
-
-The AC_CHECK_FILE macro can't be used for cross compiling as it will
-result in "error: cannot check for file existence when cross compiling".
-Replace it with the AS_IF macro.
-
-Upstream-Status: Submitted
-http://lists.freedesktop.org/archives/mesa-dev/2013-June/040168.html
-
-Signed-off-by: Jonathan Liu <net147@gmail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- configure.ac | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 70c598e..67b8c40 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1630,8 +1630,8 @@ if test "x$enable_gallium_llvm" = xyes; then
- CLANG_LIBDIR=${LLVM_LIBDIR}
- fi
- CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}
-- AC_CHECK_FILE("$CLANG_RESOURCE_DIR/include/stddef.h",,
-- AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.]))
-+ AS_IF([test ! -f "$CLANG_RESOURCE_DIR/include/stddef.h"],
-+ [AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.])])
- fi
- else
- MESA_LLVM=0
-@@ -1861,7 +1861,7 @@ if test "x$MESA_LLVM" != x0; then
- if test "x$with_llvm_shared_libs" = xyes; then
- dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
-- AC_CHECK_FILE("$LLVM_LIBDIR/lib$LLVM_SO_NAME.so", llvm_have_one_so=yes,)
-+ AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.so"], [llvm_have_one_so=yes])
-
- if test "x$llvm_have_one_so" = xyes; then
- dnl LLVM was built using auto*, so there is only one shared object.
-@@ -1869,8 +1869,8 @@ if test "x$MESA_LLVM" != x0; then
- else
- dnl If LLVM was built with CMake, there will be one shared object per
- dnl component.
-- AC_CHECK_FILE("$LLVM_LIBDIR/libLLVMTarget.so",,
-- AC_MSG_ERROR([Could not find llvm shared libraries:
-+ AS_IF([test ! -f "$LLVM_LIBDIR/libLLVMTarget.so"],
-+ [AC_MSG_ERROR([Could not find llvm shared libraries:
- Please make sure you have built llvm with the --enable-shared option
- and that your llvm libraries are installed in $LLVM_LIBDIR
- If you have installed your llvm libraries to a different directory you
-@@ -1881,7 +1881,7 @@ if test "x$MESA_LLVM" != x0; then
- --enable-opencl
- If you do not want to build with llvm shared libraries and instead want to
- use llvm static libraries then remove these options from your configure
-- invocation and reconfigure.]))
-+ invocation and reconfigure.])])
-
- dnl We don't need to update LLVM_LIBS in this case because the LLVM
- dnl install uses a shared object for each compoenent and we have
---
-1.8.2.1
-