summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.7.1.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.7.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.7.1.bb b/meta/recipes-graphics/libva/libva_2.7.1.bb
new file mode 100644
index 0000000000..b2deb017ac
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.7.1.bb
@@ -0,0 +1,23 @@
+require libva.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+SRC_URI[sha256sum] = "a00ff19d9f969259b9784172adad7788dbf3de827d985c5d27c230efd5d98a04"
+
+PACKAGECONFIG ??= " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
+"
+
+PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
+
+PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
+
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"