aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0.inc22
1 files changed, 7 insertions, 15 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0.inc b/meta/recipes-graphics/clutter/clutter-1.0.inc
index 6710776213..e1d3cf42cb 100644
--- a/meta/recipes-graphics/clutter/clutter-1.0.inc
+++ b/meta/recipes-graphics/clutter/clutter-1.0.inc
@@ -6,7 +6,7 @@ inherit clutter
SRC_URI += "file://enable_tests.patch"
-DEPENDS = "gtk-doc-native pango glib-2.0 json-glib atk udev cogl-1.0"
+DEPENDS = "pango glib-2.0 json-glib atk udev cogl-1.0"
PACKAGES =+ "${PN}-examples"
AUTOTOOLS_AUXDIR = "${S}/build"
@@ -18,28 +18,23 @@ EDEPENDS_EVDEV = "libxkbcommon"
ERDEPENDS_EVDEV = "xkeyboard-config"
# Disable pretty much everything, override in platform specific set up
-EXTRA_OECONF += "--disable-gtk-doc \
- ${@get_fpu_setting(bb, d)} \
- --disable-introspection \
- --disable-egl-backend \
+EXTRA_OECONF += "--disable-introspection \
--disable-quartz-backend \
--disable-win32-backend \
- --disable-x11-backend \
--disable-gdk-backend \
--disable-wayland-backend \
--disable-wayland-compositor \
--disable-cex100-backend \
--disable-tslib-input \
- --disable-evdev-input \
"
-PACKAGECONFIG[x11] = "--enable-x11-backend,,${EDEPENDS_X11}"
-PACKAGECONFIG[glx] = "--enable-x11-backend,,${EDEPENDS_X11} ${EDEPENDS_GLX}"
-PACKAGECONFIG[egl] = "--enable-egl-backend,,${EDEPENDS_EGL}"
-PACKAGECONFIG[evdev] = "--enable-evdev-input,,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
+PACKAGECONFIG[x11] = "--enable-x11-backend,--disable-x11-backend,${EDEPENDS_X11}"
+PACKAGECONFIG[glx] = ",,${EDEPENDS_X11} ${EDEPENDS_GLX}"
+PACKAGECONFIG[egl] = "--enable-egl-backend,--disable-egl-backend,${EDEPENDS_EGL}"
+PACKAGECONFIG[evdev] = "--enable-evdev-input,--disable-evdev-input,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
# Default configuration, distros might want to override
-PACKAGECONFIG ??= "glx"
+PACKAGECONFIG ??= "x11 glx"
FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
@@ -50,7 +45,4 @@ do_configure_prepend() {
# see https://bugzilla.gnome.org/show_bug.cgi?id=661128 for this
touch -t 200001010000 po/clutter-1.0.pot
-
- # Disable DOLT
- sed -i -e 's/^DOLT//' ${S}/configure.ac
}