aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/tidy.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/tidy.inc')
-rw-r--r--meta/recipes-graphics/clutter/tidy.inc20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/tidy.inc b/meta/recipes-graphics/clutter/tidy.inc
new file mode 100644
index 0000000000..3fa387c049
--- /dev/null
+++ b/meta/recipes-graphics/clutter/tidy.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Tidy library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+STDDEPENDS = "clutter-0.8"
+BASE_CONF = "--disable-gtk-doc"
+
+DEPENDS = "${STDDEPENDS}"
+EXTRA_OECONF = "${BASE_CONF}"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "tidy-examples"
+FILES_tidy-examples = "${bindir}/test-*"
+
+do_configure_prepend() {
+ touch ${S}/gtk-doc.make
+ sed -i s:docs/reference/Makefile::g ${S}/configure.ac
+ sed -i s:docs::g ${S}/Makefile.am
+}