aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.88.bb4
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.88.bb b/meta/recipes-extended/lsof/lsof_4.88.bb
index bc8774f9da..c0f34b6fed 100644
--- a/meta/recipes-extended/lsof/lsof_4.88.bb
+++ b/meta/recipes-extended/lsof/lsof_4.88.bb
@@ -17,12 +17,12 @@ LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d
python do_unpack () {
# temporarily change S for unpack
# of lsof_${PV}
- s = d.getVar('S')
+ s = d.getVar('S', False)
d.setVar('S', '${WORKDIR}/lsof_${PV}')
bb.build.exec_func('base_do_unpack', d)
# temporarily change SRC_URI for unpack
# of lsof_${PV}_src
- src_uri = d.getVar('SRC_URI')
+ src_uri = d.getVar('SRC_URI', False)
d.setVar('SRC_URI', '${LOCALSRC}')
d.setVar('S', s)
bb.build.exec_func('base_do_unpack', d)
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 31b71e2bc3..3cb23051f8 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -204,8 +204,8 @@ RDEPENDS_packagegroup-core-lsb-python = "\
"
def get_libqt3(d):
- if 'linuxstdbase' in d.getVar('DISTROOVERRIDES') or "":
- if 'qt3' in d.getVar('BBFILE_COLLECTIONS') or "":
+ if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
+ if 'qt3' in d.getVar('BBFILE_COLLECTIONS', False) or "":
return 'libqt-mt3'
bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x' \