aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tasks/task-poky-lsb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tasks/task-poky-lsb.bb')
-rw-r--r--meta/recipes-extended/tasks/task-poky-lsb.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-extended/tasks/task-poky-lsb.bb b/meta/recipes-extended/tasks/task-poky-lsb.bb
new file mode 100644
index 0000000000..4718f3b760
--- /dev/null
+++ b/meta/recipes-extended/tasks/task-poky-lsb.bb
@@ -0,0 +1,103 @@
+#
+# Copyright (C) 2010 Intel Corporation
+#
+
+DESCRIPTION = "Create Small Image Tasks"
+PR = "r1"
+
+PACKAGES = "\
+ task-poky-lsb \
+ task-poky-sys-extended \
+ task-poky-sys-extended-dbg \
+ task-poky-sys-extended-dev \
+ task-poky-db \
+ task-poky-db-dbg \
+ task-poky-db-dev \
+ task-poky-misc \
+ task-poky-misc-dbg \
+ task-poky-misc-dev \
+ task-poky-perl \
+ task-poky-perl-dbg \
+ task-poky-perl-dev \
+ task-poky-python \
+ task-poky-python-dbg \
+ task-poky-python-dev \
+ task-poky-tcl \
+ task-poky-tcl-dbg \
+ task-poky-tcl-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-poky-lsb = "\
+ task-poky-sys-extended \
+ task-poky-db \
+ task-poky-misc \
+ task-poky-perl \
+ task-poky-python \
+ task-poky-tcl \
+ "
+
+#
+# GPLv2 Should List
+RDEPENDS_task-poky-sys-extended = "\
+ curl \
+ diffutils \
+ gamin \
+ hdparm \
+# libaio \
+ libxml2 \
+ lrzsz \
+ lzo \
+# mdadm \
+ minicom \
+ neon \
+ parted \
+ pth \
+ quota \
+# screen \
+ setserial \
+ sysstat \
+ unzip \
+# watchdog \
+ which \
+ zip \
+ "
+
+RDEPENDS_task-poky-db = "\
+ db \
+ sqlite3 \
+ "
+
+RDEPENDS_task-poky-perl = "\
+ gdbm \
+ perl \
+ zlib \
+ "
+
+
+RDEPENDS_task-poky-python = "\
+ expat \
+ gdbm \
+ gmp \
+ ncurses \
+ openssl \
+ python \
+ readline \
+ zip \
+ "
+
+RDEPENDS_task-poky-tcl = "\
+ tcl \
+ "
+
+RDEPENDS_task-poky-misc = "\
+ elfutils \
+ gettext \
+ lsof \
+ ncurses \
+ strace \
+ libusb1 \
+ usbutils \
+ zlib \
+ "