aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/quota/quota_4.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/quota/quota_4.01.bb')
-rw-r--r--meta/recipes-extended/quota/quota_4.01.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/quota/quota_4.01.bb b/meta/recipes-extended/quota/quota_4.01.bb
index 80159a9ad4..e171160abf 100644
--- a/meta/recipes-extended/quota/quota_4.01.bb
+++ b/meta/recipes-extended/quota/quota_4.01.bb
@@ -15,12 +15,17 @@ SRC_URI[sha256sum] = "a36300bbc126b79b745bf937245092808b4585aa3309ef3335d4ab9d87
S = "${WORKDIR}/quota-tools"
-DEPENDS = "gettext-native e2fsprogs"
+DEPENDS = "gettext-native e2fsprogs libtirpc"
inherit autotools gettext
EXTRA_OEMAKE += 'STRIP=""'
+do_configure_prepend() {
+ export CFLAGS="${CFLAGS} -I${STAGING_INCDIR}/tirpc"
+ export LDFLAGS="-ltirpc ${LDFLAGS} "
+}
+
do_install() {
oe_runmake prefix=${D}${prefix} install
}