aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/psmisc/psmisc.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/psmisc/psmisc.inc')
-rw-r--r--meta/recipes-extended/psmisc/psmisc.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-extended/psmisc/psmisc.inc b/meta/recipes-extended/psmisc/psmisc.inc
index 66a784b53c..527a1d590f 100644
--- a/meta/recipes-extended/psmisc/psmisc.inc
+++ b/meta/recipes-extended/psmisc/psmisc.inc
@@ -16,6 +16,15 @@ S = "${WORKDIR}/psmisc-${PV}"
inherit autotools gettext
+# Upstream has a custom autogen.sh which invokes po/update-potfiles as they
+# don't ship a po/POTFILES.in (which is silly). Without that file gettext
+#doesn't believe po/ is a gettext directory and won't generate po/Makefile.
+EXTRA_AUTORECONF=""
+do_configure_prepend() {
+ ( cd ${S} && po/update-potfiles )
+}
+
+
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"