aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.1.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.1.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/meta/recipes-extended/parted/parted_3.1.bb b/meta/recipes-extended/parted/parted_3.1.bb
index 2d720270d8..1e07da4d60 100644
--- a/meta/recipes-extended/parted/parted_3.1.bb
+++ b/meta/recipes-extended/parted/parted_3.1.bb
@@ -11,13 +11,34 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
file://syscalls.patch \
file://fix-git-version-gen.patch \
file://fix-doc-mandir.patch \
- file://fix-dvh-overflows.patch"
+ file://fix-dvh-overflows.patch \
+ file://run-ptest \
+ file://Makefile \
+"
SRC_URI[md5sum] = "5d89d64d94bcfefa9ce8f59f4b81bdcb"
SRC_URI[sha256sum] = "5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15"
EXTRA_OECONF = "--disable-device-mapper"
-inherit autotools pkgconfig gettext
+inherit autotools pkgconfig gettext ptest
BBCLASSEXTEND = "native"
+
+do_compile_ptest() {
+ oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
+}
+
+do_install_ptest() {
+ t=${D}${PTEST_PATH}
+ mkdir $t/build-aux
+ cp ${S}/build-aux/test-driver $t/build-aux/
+ cp -r ${S}/tests $t
+ cp ${WORKDIR}/Makefile $t/tests/
+ for i in print-align print-max dup-clobber duplicate fs-resize; \
+ do cp ${B}/tests/.libs/$i $t/tests/; \
+ done
+ sed -e 's| ../parted||' -i $t/tests/*.sh
+}
+
+RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup"