aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.17.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.17.bb b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
new file mode 100644
index 0000000000..d591fbd3d2
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
@@ -0,0 +1,27 @@
+require recipes-extended/newt/libnewt_${PV}.bb
+
+SUMMARY .= " - python"
+DEPENDS = "libnewt python"
+RDEPENDS_${PN} += "python-core"
+
+inherit pythonnative python-dir
+
+EXTRA_OECONF += "--with-python"
+EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
+
+
+do_compile () {
+ VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
+ oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
+}
+
+do_install () {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
+ install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
+}
+
+PACKAGES_remove = "whiptail"
+
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"