aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/newt/files/fix_SHAREDDIR.patch')
-rw-r--r--meta/recipes-extended/newt/files/fix_SHAREDDIR.patch12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch b/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
index 7795260388..b0a1e8c105 100644
--- a/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
+++ b/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
@@ -9,17 +9,22 @@ ensure the directory ${SHAREDDIR} exists.
We need to push the patch to upstream.
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+diff --git a/Makefile.in b/Makefile.in
--- a/Makefile.in
+++ b/Makefile.in
-@@ -114,12 +114,12 @@
+@@ -128,12 +128,12 @@ $(SHAREDDIR):
sharedlib: $(LIBNEWTSH)
-$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
+$(LIBNEWTSH): $(SHAREDOBJS)
$(CC) -shared -o $(LIBNEWTSH) $(SHLIBFLAGS) $(SHAREDOBJS) $(LDFLAGS) $(LIBS)
- ln -fs $(LIBNEWTSONAME) libnewt.so
+ ln -fs $(LIBNEWTSONAME) libnewt.$(SOEXT)
ln -fs $(LIBNEWTSH) $(LIBNEWTSONAME)
-$(SHAREDDIR)/%.o : %.c
@@ -27,3 +32,6 @@ Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
$(CC) $(SHCFLAGS) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
install: $(LIBNEWT) install-sh whiptail
+--
+1.8.1.2
+